Linux升级Python版本

发布时间:2019-09-12 08:02:20编辑:auto阅读(36)


    安装升级Python

    linux自带的python是2.6版本的,用习惯了2.7.x,所以想升级python2

    1.下载源码包,后面的下载链接直接在python官网找的,如果想安装更高的版本自行更换

    wget https://www.python.org/ftp/python/2.7.10/Python-2.7.10.tgz

    2.解压压缩包

    tar xvf Python-2.7.10.tgz

    3.指定安装目录

    cd Python-2.7.10
    ./configure --prefix=/usr/local/python2

    4.安装编译

    make
    make install

    5.创建链接将python指向2.7版本
    python默认是指向2.6版本的

    删除原有的指向2.6的链接,创建新的链接指向2.7,执行python可以看到已经指向2.7版本了

    rm -f /usr/bin/python
    ln -s /usr/local/python2/bin/python /usr/bin/python

    这个时候,千万别手贱删除原有的python2.6.因为这个时候原来的yum已经不能用了。怎么修复呢?
    打开/usr/bin/yum文件,制指定python版本为原来系统的python2.6

    #! /usr/bin/python 修改为 #! /usr/bin/python2.6

    安装 setuptools

    进入 setuptools 下载页面,下载 setuptools 源码包。

    # wget https://pypi.python.org/packages/6f/10/5398a054e63ce97921913052fde13ebf332a3a4104c50c4d7be9c465930e/setuptools-26.1.1.zip#md5=f81d3cc109b57b715d46d971737336db
    

    下载完成之后,解压缩,然后进入压缩后的目录:

    # unzip setuptools-26.1.1.zip
    # cd setuptools-26.1.1

    安装:

    # python setup.py install

    安装 pip

    进入 pip 下载页面,下载 pip 源码包。

    # wget --no-check-certificate https://pypi.python.org/packages/e7/a8/7556133689add8d1a54c0b14aeff0acb03c64707ce100ecd53934da1aa13/pip-8.1.2.tar.gz#md5=87083c0b9867963b29f7aba3613e8f4a
    

    下载完成之后,解压缩,然后进入压缩后的目录:

    # tar -zxvf pip-8.1.2.tar.gz
    # cd pip-8.1.2

    安装:

    # python setup.py install

    错误处理

    在安装过程中,如果提示如下错误:

    RuntimeError: Compression requires the (missing) zlib module

    需要先安装 zlib:

    # yum install zlib
    # yum install zlib-devel

    进入Python文件夹,再重新编译 python2.7

    # make clean
    # make
    # make install
    然后进入 setuptools 和 pip 目录,重新安装。

    错误处理

关键字